Subaru BRZ Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey guys, so just picked up my 2015 BRZ few weeks ago got around 1000km on it. It has been working amazing, but the other day after work i go to start it and it had a really hard time turning over(I mean chugging for a while and barely starting).
Thought it was a fluke, same thing happened again the next day after work. The strange thing is it starts fine off a cold start when its around -5c out, but after sitting in the sun for 8 hours and the temperature being around 10c it just doesn't
seem to want to start. I was thinking it could have something to do with the temperature change, maybe causing moisture to build up somewhere?

I have been breaking it in, keeping the revs under 3.5k to 4k and I try to go easy on the engine until the temperature warms up.

Any thoughts, because this is starting to stress me out a little lol.
 

·
Registered
Joined
·
483 Posts
Do you have pushbutton start? If so the start cycle is preprogrammed and should sound the same every time. Only in very cold weather is cranking speed affected. Modern fuel injected engines start up first time every time unless there's a fault. Mine starts easily from minus 35C to plus 35C without exception.

I'd just take this in for warranty service right away.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
No just regular key start. Everything seems to be running smoothly again, but if it acts up one more time i'll take it in for a warranty service.
 
1 - 3 of 3 Posts
Top